Prerequisites and Minimum Requirements

From ProxCP Documentation
Jump to: navigation, search

ProxCP is tested and developed in a Linux environment. Windows installations are not guaranteed, tested, or supported.

Proxmox

  • Minimum Proxmox version: Proxmox VE 5.2 (released 2018-05-16)
  • Highly recommended: install Proxmox from ISO; not on top of Debian installation

Web Server

  • Note: the ProxCP web application will run on cPanel servers
  • PHP 7.2 (ProxCP will not work on older versions)
    • MySQLi extension
    • PDO extension
    • GD extension
    • Curl with SSL extension
    • ionCube Loader 10.2 or above
    • JSON support
    • XML support
    • MBstring extension
    • Iconv extension
    • OpenSSL support extension
    • PHP Mail support
  • Any web server (tested with Apache)
  • MySQL

Daemon Server

  • Note: the ProxCP daemon is a packaged NodeJS application. It is recommended to run the daemon on a separate server from the ProxCP web server but this is not required.
  • Note: DO NOT run the ProxCP daemon from a web-accessible directory
  • NodeJS 10.x or above
  • PHP 7.2 (ProxCP will not work on older versions)
    • PHP CLI support
    • MySQLi extension
    • PDO extension
    • GD extension
    • Curl with SSL extension
    • ionCube Loader 10.2 or above (with CLI support)
    • JSON support
    • XML support
    • MBstring extension
    • Iconv extension
    • OpenSSL support extension
    • PHP Mail support (sendmail)
  • MySQL